SELECT * FROM nls_database_parameters WHERE parameter LIKE '%CHARACTERSET%';


Posted by 두억시니 트랙백 0 : 댓글 0


ORA-12705

NLS 데이터 파일에 액세스할 수 없거나 부적합한 환경이 지정되었습니다.



기존 라이브러리를 추출하던중 나타난 접속 오류.
해당 노트북에는 Oracle 9i, Toad 10.6, instantclient 10 이 설치되어 있었다.

해경 방법 : [내 컴퓨터] - [시스템 등록 정보] - [고급] - [환경변수] 에 들어가서 아래의 [시스템 변수] 에 추가

( 변수 : NLS_LANG | 값 :  KOREAN_KOREA.KO16MSWIN949 )

시스템 등록 정보 - 환경 변수

시스템 변수 에 NLS_LANG 을 추가한다.(새로 만들기)

 

Toad 는 정상 접속 되는걸 보니, 이녀석은 Instantclient 로 붙었나 보다.ㅡ,.,ㅡ; 시작부터 삐걱거리네. ㅎㅎ
Posted by 두억시니 트랙백 0 : 댓글 1
오라클의 경우 데이타가 들어있는 컬럼의 형식(타입)은 변경할수 없다. 임시 컬럼을 생성하여 자료를 백업해 두었다가 복원하는 방법으로 적용한다.

-- 임시 컬럼 생성
alter table [Table_Name] add ( [Temporary_Column] varchar2(1) default 'N');


-- 임시 컬럼에 자료 백업
update [Table_Name]
set [Temporary_Column] = [To_Change_Column];


-- 원본 컬럼 삭제
alter table [Table_Name] drop column [To_Change_Column];


-- 원본 컬럼 다시 생성
alter table [Table_Name] add ( [To_Change_Column] varchar2(1) default 'N' );


-- 원본 컬럼 복원
update [Table_Name]
set [To_Change_Column] = [Temporary_Column];


-- 임시 컬럼 삭제
alter table [Table_Namedrop column [Temporary_Column];

Posted by 두억시니 트랙백 0 : 댓글 0
참으로 힘들었던 설치였다. 설치가 된것처럼 보이면서도 patch 도중 계속적인 appcrash 오류 때문에 몇번을 고스트 복원을 했었던지 셀수도 없을것 같다. 하지만, 끈질기게 찾아내서 결국 모두 완벽하게(?) 성공시켰고, 여러가지 문제점들은 모두 해결되었다. 최신의 노트북에도 파워빌더 시리즈를 설치해 보자. 아 피눈물 날것 같아. ㅠ_ㅜ


[작성자의 개발환경] 열기




<파워빌더 설치전 준비사항>
ntwdblib.dll 최신 파일 - 첨부파일을 C:\WINDOWS\SYSTEM 폴더에 복사한다.(SYSTEM32 폴더가 아니다.)
윈도우즈7 도움말 패치 - 패치를 먼저 설치하고 파워빌더 설치할것을 권장한다.
아웃룩 키보드 입력 변경 - 아웃룩을 설치했다면 키보드 구성을 삭제/변경 해줘야 한다.


 
<설치시 주의사항>
구지 관리자/호환성 모드로 설치할 필요는 없다. 특히 윈도우 XP/2000/2003 의 호환성이 좋을거란 착각으로 마우스 오른쪽 버튼으로 설치해봤는데, 이것때문에 더 오류가 발생하였다. 프린터 드라이버는 비스타(64bit)용을 구해서 설치해도 된다. 사무실의 HP LaserJet 1320의 경우 윈도우즈7 드라이버를 제공하지 않았다.


 
<지금까지 확인된 파워빌더 버전별 설치 오류와 대처방안>
PowerBuilder 6.0/6.5
정상적으로 설치되었다고 생각했으나, 시작시 오류 메시지가 출력된다.
폰트가 변경이 안되고 저장이 안된다.
- 설치폴더(C:\Sybase\PWRS\PB6)의 pb.ini 파일을 건드려 줘야 했다. 어떤 부분이었는지는 잊어버려서 추후 내용을 수정해야 할것 같다. ㅋㅋ 참고용으로 정상적으로 동작하는 나의 pb.ini 를 올려본다.

[pb.ini] 열기


PowerBuilder 7.0
폰트가 변경이 안되고 저장이 안된다.

PowerBuilder 8.0
설치하기 전에 우선 Microsoft Java VM을  설치해야 오류 없이 설치 할수 있었다.
-. 그런데 Java VM이 어떤 녀석이었던 건지 잊어 버렸다. 다시 곰곰히 생각해보자.

PowerBuilder 9.0
별다른 문제없이 설치된다. 간혹 오류 메시지가 나올 수 있으나 무시하고 사용해도 괜찮았다.

PowerBuilder 10.5
patch가 되질 않는다.
64비트 OS를 감지했다는 메시지를 볼수 있는데 과감하게 '아니오'를 누르자.

PowerBuilder 11.5
별다른 문제없이 설치된다.
64비트 OS를 감지했다는 메시지를 볼수 있는데 과감하게 '아니오'를 누르자.
Posted by 두억시니 트랙백 0 : 댓글 0